Resolução correta no Ubuntu 11.04 em placas SiS 671/672/771, e solução de possível desempenho ruim

Categoria: Ubuntu | Palavras-chave: , , , , , ,

Notícia muito boa aos proprietários de placas SiS que assim como eu, ficaram sem o Unity 3D, mas que não perdem a esperança de um dia conseguir poder utilizar o Compiz em nossos computadores ou notebooks.

Mas antes da solução final, uma pequena história. Na manhã do dia 28 – quinta-feira – amanheci com um ar de animação, o novo Ubuntu estava por vir, melhor do que nunca – sim, sou do time que apoia o Unity. Chequei alguns sites sobre Ubuntu por volta das seis da manhã, e nenhum continha informações sobre a versão atual. Como todas as manhãs de segunda à sexta, me arrumei para ir para a escola, e sete em ponto eu estava lá. Durante o intervalo da 2ª para a 3º aula, peguei me celular para checar se já houvera o lançamento do Ubuntu 11.04 e vi que havia ocorrido.

Chegando em casa, por volta das 11:30, tentei colocar pra baixar, mas como a internet estava muito ruim, esperei pela hora do almoço na casa de minha vó para poder baixar, já que – é exatamente da casa dela onde redigo esse texto – aqui a rede é muito boa. Fui almoçar e deixei baixando, quando retornei restavam apenas 2 horas e 40 minutos, então, fui para casa, sai, fui para o reforço de matemática, fui no comércio comprar uns DVDs pra fazer o backup, e quando cheguei na casa de minha avó por volta de cinco da tarde, salvei tudo o que tinha pra salvar e então instalei.

Lá vou eu todo ansioso pra testar o Ubuntu na sua versão final – venho testando desde o alpha 2 e sabia exatamente o que fazer ao iniciar pela primeira vez. Coloquei o driver sismedia – que mostrarei como fazer daqui a pouco – mas encontrei um grande problema, o sistema estava muito lento, quase impossível de utilizar, mas aí encontrei a solução em algo que não tinha nada haver com o assunto.

O que fiz foi seguir alguns passos pra corrigir o plymouth e voilà o sistema estava muito rápido. Não sei se vai funcionar na sua máquina, mas é bem possível que sim. Mas agora, vamos à instalação do driver sismedia, para o qual eu criei um script para facilitar tudo.

Download do script (atualizado)

Basta que baixe, descompacte e rode pelo terminal

Vamos agora corrigir o desempenho. Faça isso:

1 – No Terminal, digite:

sudo gedit /etc/default/grub

2 -Localize a linha “#GRUB_GFXMODE=640×480” e, abaixo dela, adicione a seguinte:

GRUB_GFXPAYLOAD_LINUX=1280×800

4 – Atualize as configurações do Grub e gere uma nova imagem initramfs:

sudo update-grub2 && sudo update-initramfs -u

5 – Reinicie o sistema.

Fácil não?

PS: O tema sairá sim, fiquem frios, mais tardar amanhã e eu também vou trazer um aviso com relação aos temas.

Até mais, abraço a todos.

Publicado em 30 de abril de 2011 | 28 Comentários

Anderson Henrique

Anderson Henrique

Estudante de programação onde aprende tudo pela internet, também é nerd e sonha criar uma distribuição Linux que seja tão intuitiva quanto o Ubuntu. Esporte predileto: tentar converter as pessoas a usarem Linux em especial Ubuntu... mesmo que com pouco sucesso.

Mais posts do autor (24)

28 Comentários

  1. Vitor disse:

    Valeu pelas dicas! Tenho um amigo com a placa SiS671 em um notebook, sofri pra fazer funcionar a resolução correta.

    A diferença é que o sistema estava lento até eu colocar o driver da placa de vídeo, e aí então ficou rápido de novo.

    E… internet rápida baixando 700MB em 2h e 40min? LOL, vou deduzir que sua internet é de 500kbps… isso não é muito rápido hehe
    Ou você baixou por http/ftp no dia do lançamento, o que não é recomendável… baixar por torrent vai rapidinho, velocidade máxima :)

  2. Anderson Henrique disse:

    Se você morasse onde eu moro, iria torcer pra ter uma internet de 600. A Oi Velox aqui é a melhor que tem, sendo minha esperança um dia a GVT chegar aqui em Sergipe.

  3. Alexandre disse:

    Estava meu sistema muito lento, fiz o descrito no post, e ficou muito melhor.
    Muito obrigado.

  4. PC disse:

    Amigos, tudo bem? Gostaria de agradecer a dica. Realmente, dá certinho. Funcionou perfeitamente. No entanto, às vezes acontece o seguinte: eu ligo ou reinicio o PC e, após carregar o Ubuntu e chegar na tela de login, a resolução de tela está baixa novamente, ou seja, voltou para 800×600, igual era antes. Aí, eu reinicio o PC e, ao carregar o Ubuntu novamente, tudo volta ao normal (resolução correta de 1280×800). Isso acontece com frequência. Eu diria que, a cada 10 vezes que ligo ou reinicio o PC, isso acontece umas 2 ou 3 vezes. Alguém saberia dizer o que pode ser? Existe alguma outra configuração que se pode fazer para “forçar” ele a sempre iniciar em 1280×800, por exemplo, para evitar tal problema? Minha placa é a SiS 671. Fora esse inconveniente ocasional, funciona normalmente. Recomendo a dica. Agradeço a atenção de todos. Abraço. Paulo César.

  5. jsilva69 disse:

    Perdonen, pero va en español!

    Pueden probar con un driver precompilado que encontre en una web china…

    1) Descargar el archivo xorg-driver-sis671-ubuntu11.04.tar.gz desde
    http://www.4shared.com/file/xtT3dUny/xorg-driver-sis671-ubuntu1104t.html
    Descomprimir.
    2) Copiar el archivo sis671_drv.so en /usr/lib/xorg/modules/drivers
    3) Copiar el archivo xorg.conf en /etc/X11/
    4) Reiniciar.

    Suerte!

  6. Eu uso o Debian Squeeze e um driver semelhante a esse aí no meu notebook. A instabilidade de resolução a cada boot realmente é constante. Não é necessário reiniciar todo o sistema, apenas reiniciar o servidor x.
    Esse driver também traz alguns problemas com o plymouth e players de vídeo. A aceleração 3D que se consegue é mínima até mesmo se você instala os drivers originais no próprio Windows.
    Ainda vai demorar um pouquinho, mais pretendo comprar um notebook de vergonha com chip gráfico decente. Nunca mais compro nada com SiS ou VIA, ou mesmos produtos da Positivo.

  7. Flávio disse:

    Cara, muito obrigado! Finalmente consegui instalar esse driver.

    Só uma dica, para evitar erros de pacotes não instalados, é melhor incluir no script estas linhas:
    sudo apt-get install git
    sudo apt-get build-dep xserver-xorg-video-sis

    Abraço!

  8. Denner Peterlini disse:

    Valeu cara, deu certo aqui também. Adiciionei a segunda linha da dica do flávio aí em cima e eliminei erros de dependências do xorg que estava tendo aqui na minha instalação. Abração

  9. leodeusdead disse:

    Blz só uma coisa.
    No script, no apt-get está faltando um ” – ” no build-essential.
    Mas aqui deu certo.

  10. […] você reparar lentidão no sistema uma dica que encontrei no site Ubuntero pode ajudar . Editaremos uma entrada do grub, para isso digite no terminal: sudo gedit […]

  11. Roberto disse:

    Po galera, comigo acontece o seguinte, quando chega na primeira etapa na qual tenho que executar o comando “sudo gedit /etc/default/grub” ele me diz o seguinte: (gedit:22257): Gtk-WARNING **: cannot open display: :0

    Oque rolou de errado?
    me da uma força ae
    vlw abraço

  12. Roberto disse:

    Opa, perdão pelo pedido de socorro, já foi resolvido.
    Nubagem de iniciante
    hehe
    obrigado pelo post!

  13. SuaMae disse:

    não funcionou comigo, segui tudo à risca, quando iniciei o sistema novamente não havia mudado, e também não habilitou a resolução 1280×800 nas configurações. Oque eu faço?

  14. Arthur Murillo disse:

    Meu Ubuntu é 10.04 e também não funcionou, ocorreu da mesma maneira que o “SuaMae” ali em cima…

  15. Anderson Henrique disse:

    Perdão pelo transtorno, fui verificar o script novamente e vi que havia faltado um traço no nome de um pacote por isso que a instalação estava dando errado, deve estar funcionando perfeitamente agora.

  16. Leewan disse:

    Excelente, o único que funcionou e venho buscando na net faz 2 noites. Flw.

  17. Alexandre disse:

    Anderson Henrique, muito Obrigado e que Deus te abençôe imensamente.
    Depois de tanto fuçar na net testanto tudo o que achei de tutorial, finalmente consegui, já tinha instalado vários drives, editado o xorg.conf, até instalei drives do Mageia, mas nada funcionou, então resolvi seguir esse tutorial e deu certo.
    Notebook Positivio Premium
    Linux Mint 17.1 funcionando com resolução 1024×768, perfeitamente.

  18. Tiago Abreu disse:

    Este tuturial ja tem uns bons anos e ainda funciona no xubuntu 15.04 para a resolucao de 1024×768.
    Muito obrigado e parabens.

  19. Jaques disse:

    Incrível! Já tinha perdido as esperanças tentando fazer um notebook Philco (PHN 14122) com placa SIS M 672 FX + SIS 968 sair da gaiola de 640×480. Até que resolvi tentar usar sua sugestão apesar de ser xubuntu 14.04 e para meu espanto funcionou!! Não tenho como agradecer!

  20. Marcus Roberto Pereira disse:

    Muito obrigado amigo deu tudo certo agora só estou com problemas com o som, não sai nada.

  21. DgsDaRoça disse:

    CARA vlw de mais a dica, foi o unico que funcionou, funcionou no 14.4 LTS tbm. Porem o arquivo para baixar não esta mais disponivel, o que ajudou foi a dica do Jsilva69

    Perdonen, pero va en español!

    Pueden probar con un driver precompilado que encontre en una web china…

    1) Descargar el archivo xorg-driver-sis671-ubuntu11.04.tar.gz desde
    http://www.4shared.com/file/xtT3dUny/xorg-driver-sis671-ubuntu1104t.html
    Descomprimir.
    2) Copiar el archivo sis671_drv.so en /usr/lib/xorg/modules/drivers
    3) Copiar el archivo xorg.conf en /etc/X11/
    4) Reiniciar.

    Suerte!

    Ubuntu sis 671/72, sis 771/671

  22. sourogerio disse:

    Informo que nessa data um note positivo Z80 rodando lubuntu 16.04, melhorou sua resolução de vídeo seguindo as orientações inseridas por Anderson Henrique.

    Obrigado

  23. Fábio Consalter disse:

    Também informo que hoje fiz o procedimento e mesmo depois de tanto tempo, tudo funcionou perfeitamente no meu Positivo Premium P237s, com sis 3 Mirage m672. Está rodando a 1280×800, tão rápido quanto possível, no Xubuntu 16.04 LTS.
    Somente o script não conseguiu baixar o driver, baixei pela dica do jsilva69.
    Obrigado

    • Fábio Consalter disse:

      Na verdade, corrigindo, estava rodando a 1024×768. Na net achei uma distro, Mageia, baseada no antigo Mandriva, que dá suporte a essa placa e outras antigas, e está rodando bem. Usa pacotes rpm e não deb, mas estou me acostumando.

    • Fábio Consalter disse:

      Na verdade, corrigindo, estava rodando a 1024×768. Na net achei uma distro, Mageia, baseada no antigo Mandriva, que dá suporte a essa placa e outras antigas, e está rodando bem. Usa pacotes rpm e não deb, mas estou me acostumando.